Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Want to use Faceswap in The Cloud? This is not directly supported by the Devs, but you may find community support here


Forum rules

Read the FAQs and search the forum before posting a new topic.

NB: The Devs do not directly support using Cloud based services, but you can find community support here.

Please mark any answers that fixed your problems so others can find the solutions.

Post Reply
User avatar
cuplearner
Posts: 4
Joined: Wed Jan 20, 2021 9:29 am
Been thanked: 1 time

Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Post by cuplearner »

As what you see ,why the faceswap2.0 need python 3.7.Can we use python 3.6 on faceswap2.0? Then one who dose not have a high level GPU can try some other models on Google colab.


User avatar
torzdf
Posts: 1173
Joined: Fri Jul 12, 2019 12:53 am
Answers: 119
Has thanked: 37 times
Been thanked: 232 times

Re: Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Post by torzdf »

Unfortunately we use functions in Faceswap that are not available in Python 3.6.

I couldn't say what they are off the top of my head, and since we don't directly support Collab I am unlikely to spend the time going through the code and backporting these functions.

Python 3.6 is now 5 years old, so the onus should be on Google to update to a more recent release then for us to back port, however we do welcome Pull Requests to improve compatibility.

My word is final


User avatar
cuplearner
Posts: 4
Joined: Wed Jan 20, 2021 9:29 am
Been thanked: 1 time

Re: Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Post by cuplearner »

:idea: so the problem is money.


User avatar
AtlasRedux
Posts: 9
Joined: Tue Feb 16, 2021 11:05 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Post by AtlasRedux »

cuplearner wrote: Tue Feb 02, 2021 2:56 am

:idea: so the problem is money.

What? No, the problem is Python 3.6 is outdated. It can't do features the software needs. 3.6 is dead. Almost no one uses that anymore. You can't magically get 3.6 to work with new APIs and features.

That's like asking for Windows 3.11 to suddenly be as good as Windows 10.
It's just not possible.
You'd have to completely rewrite it ... and that is what was done. And the rewrite is 3.7.


User avatar
police.bike
Posts: 21
Joined: Tue Jun 30, 2020 3:37 pm
Has thanked: 7 times
Been thanked: 5 times

Re: Why the faceswap2.0 need python 3.7,on Google colab we only have python 3.6

Post by police.bike »

Update - Feb 20, 2021

I was able to get both python 3.7 & 3.8 working on google collab and train using latest versions. Pretty amazing ones !

Just use this as block 1 before running any steps within the Collab notebook

Code: Select all

!sudo apt install python3.7
!update-alternatives --install /usr/local/bin/python3 python3 /usr/bin/python3.6 1
!update-alternatives --install /usr/local/bin/python3 python3 /usr/bin/python3.7 2
!python --version
!sudo apt update && upgrade
!sudo apt install python3-pip
!python -m pip install --upgrade pip
!pip --version
!python --version
!pip --version

Change 3.7 to 3.8 if you need it. This will reset python runtime to 3.7.5 and will get latest faceswap editions working.

Have fun !!!


Post Reply