Installed on nVidia but Not Using GPU while Extracting or Training

Installing and setting up FaceSwap


Forum rules

Read the FAQs and search the forum before posting a new topic.

Please mark any answers that fixed your problems so others can find the solutions.

Post Reply
User avatar
haoylee
Posts: 7
Joined: Thu Nov 18, 2021 3:16 pm
Has thanked: 1 time
Been thanked: 1 time

Installed on nVidia but Not Using GPU while Extracting or Training

Post by haoylee »

Hi,

I recently reinstalled my computer and never got back normal with my faceswap since (and I hadn't been using this program for months). Specially, I couldn't get my GPU running for extracting and training. The resource usage is always on CPU (12Cores24Threads all at 90-100% usage, while GPU at below 10%), said GPU-Z, and my system performance monitor said Cuda usage is also 0. And more obviously, the process became painfully slow compared to my old good time using GPU training Origianl Model. It used to be like at least 20-30EGs/sec but it was 13 this time. (Could be a false memory but maybe you can tell me a typical number for GPU training?) Also, the extracting phase took me 4 hours to extract a 20min clip when it used to be like half an hour.

GPU Info:
RTX 2080 Ti, Studio Driver 472.47 (11/10/2021)

At Fist, I even couln't get the proagram window open because the command window said that tensorflow-gpu package was not installed so there's an error importing tensorflow. So I tried many many times to reinstall and every time I would check if there was any package missing.

Then this time the program window did pop up but, when I checked my installation detail it said cuda toolkit package wasn't installed. The command window repoted no errors, but the process only used my CPU and never used GPU. So I went to nvidia website to download manually - the newest version CUDA toolkit 11.5. After installation and restarting system, the situation hadn't been changed, still painfully slow.

So what'd I miss here? Is there any other packages I miss or some driver/toolkit version unsupoorted?

Here's my sys info, grateful if somebody could help:

Code: Select all

============ System Information ============
encoding:            cp936
git_branch:          master
git_commits:         808e008 Bugfix -Weights freezing/loading for dfl-sae
gpu_cuda:            11.5
gpu_cudnn:           No global version found. Check Conda packages for Conda cuDNN
gpu_devices:         GPU_0: NVIDIA GeForce RTX 2080 Ti
gpu_devices_active:  GPU_0
gpu_driver:          472.47
gpu_vram:            GPU_0: 11264MB
os_machine:          AMD64
os_platform:         Windows-10-10.0.19043-SP0
os_release:          10
py_command:          C:\Users\LHY\faceswap/faceswap.py gui
py_conda_version:    conda 4.10.3
py_implementation:   CPython
py_version:          3.8.12
py_virtual_env:      True
sys_cores:           24
sys_processor:       AMD64 Family 23 Model 113 Stepping 0, AuthenticAMD
sys_ram:             Total: 65444MB, Available: 56970MB, Used: 8474MB, Free: 56970MB

=============== Pip Packages ===============
absl-py==0.15.0
astunparse==1.6.3
cachetools==4.2.4
certifi==2021.10.8
charset-normalizer==2.0.7
clang==5.0
cycler==0.10.0
fastcluster==1.1.26
ffmpy==0.2.3
flatbuffers==1.12
gast==0.4.0
google-auth==1.35.0
google-auth-oauthlib==0.4.6
google-pasta==0.2.0
grpcio==1.42.0
h5py==3.1.0
idna==3.3
imageio @ file:///tmp/build/80754af9/imageio_1617700267927/work
imageio-ffmpeg @ file:///home/conda/feedstock_root/build_artifacts/imageio-ffmpeg_1629987409325/work
importlib-metadata==4.8.2
joblib @ file:///tmp/build/80754af9/joblib_1635411271373/work
keras==2.6.0
Keras-Preprocessing==1.1.2
kiwisolver @ file:///C:/ci/kiwisolver_1612282606037/work
Markdown==3.3.6
matplotlib @ file:///C:/ci/matplotlib-base_1592837548929/work
mkl-fft==1.3.0
mkl-random==1.1.1
mkl-service==2.3.0
numpy @ file:///C:/ci/numpy_and_numpy_base_1603466732592/work
nvidia-ml-py==11.495.46
oauthlib==3.1.1
olefile @ file:///Users/ktietz/demo/mc3/conda-bld/olefile_1629805411829/work
opencv-python==4.5.4.58
opt-einsum==3.3.0
Pillow==8.4.0
protobuf==3.19.1
psutil @ file:///C:/ci/psutil_1612298324802/work
pyasn1==0.4.8
pyasn1-modules==0.2.8
pyparsing @ file:///tmp/build/80754af9/pyparsing_1635766073266/work
python-dateutil @ file:///tmp/build/80754af9/python-dateutil_1626374649649/work
pywin32==228
requests==2.26.0
requests-oauthlib==1.3.0
rsa==4.7.2
scikit-learn @ file:///C:/ci/scikit-learn_1635188126022/work
scipy @ file:///C:/ci/scipy_1616703433439/work
sip==4.19.13
six==1.15.0
tensorboard==2.6.0
tensorboard-data-server==0.6.1
tensorboard-plugin-wit==1.8.0
tensorflow-estimator==2.6.0
tensorflow-gpu==2.6.2
termcolor==1.1.0
threadpoolctl @ file:///Users/ktietz/demo/mc3/conda-bld/threadpoolctl_1629802263681/work
tornado @ file:///C:/ci/tornado_1606942392901/work
tqdm @ file:///tmp/build/80754af9/tqdm_1635330843403/work
typing-extensions==3.7.4.3
urllib3==1.26.7
Werkzeug==2.0.2
wincertstore==0.2
wrapt==1.12.1
zipp==3.6.0

============== Conda Packages ==============
# packages in environment at C:\Users\LHY\MiniConda3\envs\faceswap:
#
# Name                    Version                   Build  Channel
absl-py                   0.15.0                   pypi_0    pypi
astunparse                1.6.3                    pypi_0    pypi
blas                      1.0                         mkl  
ca-certificates           2021.10.26           haa95532_2  
cachetools                4.2.4                    pypi_0    pypi
certifi                   2021.10.8        py38haa95532_0  
charset-normalizer        2.0.7                    pypi_0    pypi
clang                     5.0                      pypi_0    pypi
cycler                    0.10.0                   py38_0  
fastcluster               1.1.26           py38h251f6bf_2    conda-forge
ffmpeg                    4.3.1                ha925a31_0    conda-forge
ffmpy                     0.2.3                    pypi_0    pypi
flatbuffers               1.12                     pypi_0    pypi
freetype                  2.10.4               hd328e21_0  
gast                      0.4.0                    pypi_0    pypi
git                       2.32.0               haa95532_1  
google-auth               1.35.0                   pypi_0    pypi
google-auth-oauthlib      0.4.6                    pypi_0    pypi
google-pasta              0.2.0                    pypi_0    pypi
grpcio                    1.42.0                   pypi_0    pypi
h5py                      3.1.0                    pypi_0    pypi
icc_rt                    2019.0.0             h0cc432a_1  
icu                       58.2                 ha925a31_3  
idna                      3.3                      pypi_0    pypi
imageio                   2.9.0              pyhd3eb1b0_0  
imageio-ffmpeg            0.4.5              pyhd8ed1ab_0    conda-forge
importlib-metadata        4.8.2                    pypi_0    pypi
intel-openmp              2021.4.0          haa95532_3556  
joblib                    1.1.0              pyhd3eb1b0_0  
jpeg                      9d                   h2bbff1b_0  
keras                     2.6.0                    pypi_0    pypi
keras-preprocessing       1.1.2                    pypi_0    pypi
kiwisolver                1.3.1            py38hd77b12b_0  
libpng                    1.6.37               h2a8f88b_0  
libtiff                   4.2.0                hd0e1b90_0  
libwebp                   1.2.0                h2bbff1b_0  
lz4-c                     1.9.3                h2bbff1b_1  
markdown                  3.3.6                    pypi_0    pypi
matplotlib                3.2.2                         0  
matplotlib-base           3.2.2            py38h64f37c6_0  
mkl                       2020.2                      256  
mkl-service               2.3.0            py38h196d8e1_0  
mkl_fft                   1.3.0            py38h46781fe_0  
mkl_random                1.1.1            py38h47e9c7a_0  
numpy                     1.19.2           py38hadc3359_0  
numpy-base                1.19.2           py38ha3acd2a_0  
nvidia-ml-py              11.495.46                pypi_0    pypi
oauthlib                  3.1.1                    pypi_0    pypi
olefile                   0.46               pyhd3eb1b0_0  
opencv-python             4.5.4.58                 pypi_0    pypi
openssl                   1.1.1l               h2bbff1b_0  
opt-einsum                3.3.0                    pypi_0    pypi
pillow                    8.4.0            py38hd45dc43_0  
pip                       21.2.2           py38haa95532_0  
protobuf                  3.19.1                   pypi_0    pypi
psutil                    5.8.0            py38h2bbff1b_1  
pyasn1                    0.4.8                    pypi_0    pypi
pyasn1-modules            0.2.8                    pypi_0    pypi
pyparsing                 3.0.4              pyhd3eb1b0_0  
pyqt                      5.9.2            py38ha925a31_4  
python                    3.8.12               h6244533_0  
python-dateutil           2.8.2              pyhd3eb1b0_0  
python_abi                3.8                      2_cp38    conda-forge
pywin32                   228              py38hbaba5e8_1  
qt                        5.9.7            vc14h73c81de_0  
requests                  2.26.0                   pypi_0    pypi
requests-oauthlib         1.3.0                    pypi_0    pypi
rsa                       4.7.2                    pypi_0    pypi
scikit-learn              1.0.1            py38hf11a4ad_0  
scipy                     1.6.2            py38h14eb087_0  
setuptools                58.0.4           py38haa95532_0  
sip                       4.19.13          py38ha925a31_0  
six                       1.15.0                   pypi_0    pypi
sqlite                    3.36.0               h2bbff1b_0  
tensorboard               2.6.0                    pypi_0    pypi
tensorboard-data-server   0.6.1                    pypi_0    pypi
tensorboard-plugin-wit    1.8.0                    pypi_0    pypi
tensorflow-estimator      2.6.0                    pypi_0    pypi
tensorflow-gpu            2.6.2                    pypi_0    pypi
termcolor                 1.1.0                    pypi_0    pypi
threadpoolctl             2.2.0              pyh0d69192_0  
tk                        8.6.11               h2bbff1b_0  
tornado                   6.1              py38h2bbff1b_0  
tqdm                      4.62.3             pyhd3eb1b0_1  
typing-extensions         3.7.4.3                  pypi_0    pypi
urllib3                   1.26.7                   pypi_0    pypi
vc                        14.2                 h21ff451_1  
vs2015_runtime            14.27.29016          h5e58377_2  
werkzeug                  2.0.2                    pypi_0    pypi
wheel                     0.37.0             pyhd3eb1b0_1  
wincertstore              0.2              py38haa95532_2  
wrapt                     1.12.1                   pypi_0    pypi
xz                        5.2.5                h62dcd97_0  
zipp                      3.6.0                    pypi_0    pypi
zlib                      1.2.11               h62dcd97_4  
zstd                      1.4.9                h19a0ad4_0  

================= Configs ==================
--------- .faceswap ---------
backend:                  nvidia
by torzdf » Fri Nov 19, 2021 2:59 pm

Uninstall your global Cuda. It is conflicting with the local version that faceswap installs

Go to full post

User avatar
torzdf
Posts: 1587
Joined: Fri Jul 12, 2019 12:53 am
Answers: 127
Has thanked: 62 times
Been thanked: 301 times

Re: Installed on nVidia but Not Using GPU while Extracting or Training

Post by torzdf »

Uninstall your global Cuda. It is conflicting with the local version that faceswap installs

My word is final


User avatar
haoylee
Posts: 7
Joined: Thu Nov 18, 2021 3:16 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Installed on nVidia but Not Using GPU while Extracting or Training

Post by haoylee »

Fianlly got it worked.

Yeah this time it is the cuda I installed via nvidia website that causes the problem.

Struggled so many times, every installation has different missing packages that I have to reinstall over and over again, maybe it's because I'm from China and some sites are blocked.

Anyway, thanks for your patience bro, it is now truely running on my GPU now.


Post Reply