Index Error - Alignments

If training is failing to start, and you are not receiving an error message telling you what to do, tell us about it here


Forum rules

Read the FAQs and search the forum before posting a new topic.

This forum is for reporting errors with the Training process. If you want to get tips, or better understand the Training process, then you should look in the Training Discussion forum.

Please mark any answers that fixed your problems so others can find the solutions.

Locked
User avatar
SpArKyxRAIN
Posts: 5
Joined: Fri Apr 02, 2021 8:28 pm
Has thanked: 1 time
Been thanked: 1 time

Index Error - Alignments

Post by SpArKyxRAIN »

Oddly, I have narrowed this issue down to the alignments file. I have parsed and read quite a bit on the forum for this to see if I can find a solution. Or a solution not related that may work.

Seems like after extracting from two more videos to give some fresh data this error will keep coming up
"IndexError: tuple index out of range

I've sorted, renamed etc but to no avail. Checked the logs and it looks like it is trying to load.

""_extract_face called without a loaded image. Returning empty face.
04/02/2021""

I have 3 seperate videos I've extracted from with one of them being the main swap. But for added variation I added in two more sources .

Possible I missed something? Have log file if needed.

Thank you

-A

by torzdf » Fri Apr 02, 2021 10:16 pm

Not at all. I literally just put the "active bug" code in so I could get some more information out about what is going wrong.

So.... the issue is that you have mismatched sized faces in the training folder. I will look to put something in to catch this and output a more useful error message in future.

Basically you have a load of 512px images and 704px images in that folder. Not quite sure why you're trying to load 704px images, but there's your problem.

Because of the way we load and batch images all images must be the same size.

Go to full post
Last edited by SpArKyxRAIN on Fri Apr 02, 2021 8:53 pm, edited 1 time in total.

User avatar
torzdf
Posts: 1439
Joined: Fri Jul 12, 2019 12:53 am
Answers: 125
Has thanked: 48 times
Been thanked: 278 times

Re: Index Error - Alignments

Post by torzdf »

This is fine:
_extract_face called without a loaded image. Returning empty face.

For the other, I will need the crash report.

My word is final


User avatar
SpArKyxRAIN
Posts: 5
Joined: Fri Apr 02, 2021 8:28 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Index Error - Alignments

Post by SpArKyxRAIN »

Crash report Added

Attachments
crash_report.2021.04.02.152523364762.log
(39.29 KiB) Downloaded 89 times

User avatar
torzdf
Posts: 1439
Joined: Fri Jul 12, 2019 12:53 am
Answers: 125
Has thanked: 48 times
Been thanked: 278 times

Re: Index Error - Alignments

Post by torzdf »

Please update to latest faceswap, and run again. It will error. Please provide the crash report you receive and I should be able to diagnose.

My word is final


User avatar
SpArKyxRAIN
Posts: 5
Joined: Fri Apr 02, 2021 8:28 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Index Error - Alignments

Post by SpArKyxRAIN »

My apologies on that. Looks like an active bug being tracked. Here is updated crash report

Attachments
crash_report.2021.04.02.163719534937.log
(65.42 KiB) Downloaded 83 times

User avatar
torzdf
Posts: 1439
Joined: Fri Jul 12, 2019 12:53 am
Answers: 125
Has thanked: 48 times
Been thanked: 278 times

Re: Index Error - Alignments

Post by torzdf »

Not at all. I literally just put the "active bug" code in so I could get some more information out about what is going wrong.

So.... the issue is that you have mismatched sized faces in the training folder. I will look to put something in to catch this and output a more useful error message in future.

Basically you have a load of 512px images and 704px images in that folder. Not quite sure why you're trying to load 704px images, but there's your problem.

Because of the way we load and batch images all images must be the same size.

My word is final


User avatar
SpArKyxRAIN
Posts: 5
Joined: Fri Apr 02, 2021 8:28 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Index Error - Alignments

Post by SpArKyxRAIN »

Interesting. I would have to redo those then. I do not know why those images would of been a different size as I have kept the settings the same.

I'll update once I re-do them


User avatar
SpArKyxRAIN
Posts: 5
Joined: Fri Apr 02, 2021 8:28 pm
Has thanked: 1 time
Been thanked: 1 time

Re: Index Error - Alignments

Post by SpArKyxRAIN »

Sorted images by dimensions and re-extracted all incorrect ones. Problem solved

Thank you for all your help


Locked