Strange error when"Extracting a training set from an alignments file"

Converting source frames into swapped frames
Forum rules
Read the FAQs and search the forum before posting a new topic.

Please mark any answers that fixed your problems so others can find the solutions.
Post Reply
User avatar
allen621115
Posts: 3
Joined: Mon Mar 30, 2020 6:48 pm

Strange error when"Extracting a training set from an alignments file"

Post by allen621115 » Mon Mar 30, 2020 7:22 pm

i'm doing "Extracting a training set from an alignments file" ,when I clicked extract it printed:

"0 face(s) extracted".

Like this:


Loading...
Setting Faceswap backend to NVIDIA
Please backup your data and/or test the tool you want to use with a smaller data set to make sure you understand how it works.
03/31/2020 03:08:11 INFO Log level set to: INFO
03/31/2020 03:08:16 INFO [ALIGNMENT DATA]
03/31/2020 03:08:16 INFO Reading alignments from: 'G:\faceswap test\POLARRANA\videos\low to up_alignments.fsa'
03/31/2020 03:08:16 INFO [FRAMES DATA]
03/31/2020 03:08:16 INFO Loading video frames from G:\faceswap test\POLARRANA\videos\done low to up.mp4

03/31/2020 03:08:16 INFO [EXTRACT FACES]





03/31/2020 03:08:18 INFO 0 face(s) extracted
Process exited.

I have viewed this post,but still don't get it.
viewtopic.php?f=5&t=477&p=1550#p1550

Any help would be appreciated.
by torzdf » Tue Mar 31, 2020 9:00 am
Your frames location is wrong.

It should be "G:/faceswap test/POLARRANA/videos/low to up.mp4" (not with the word "done" in it.... assuming you haven't renamed your alignments file)
Go to full post

User avatar
torzdf
Posts: 554
Joined: Fri Jul 12, 2019 12:53 am
Answers: 86
Has thanked: 17 times
Been thanked: 121 times

Re: Strange error when"Extracting a training set from an alignments file"

Post by torzdf » Mon Mar 30, 2020 10:11 pm

Please press the "Generate" button on your command and post the output
My word is final

User avatar
allen621115
Posts: 3
Joined: Mon Mar 30, 2020 6:48 pm

Re: Strange error when"Extracting a training set from an alignments file"

Post by allen621115 » Tue Mar 31, 2020 6:40 am

Thank you,and here it is:

C:\Users\Allen\MiniConda3\envs\faceswap\python.exe G:\faceswap\tools.py alignments -j extract -a "G:/faceswap test/POLARRANA/videos/low to up_alignments.fsa" -fc "G:/faceswap test/POLARRANA/output sec2/downtoup" -fr "G:/faceswap test/POLARRANA/videos/done low to up.mp4" -o console -een 1 -sz 256 -dm -L INFO

User avatar
torzdf
Posts: 554
Joined: Fri Jul 12, 2019 12:53 am
Answers: 86
Has thanked: 17 times
Been thanked: 121 times

Re: Strange error when"Extracting a training set from an alignments file"

Post by torzdf » Tue Mar 31, 2020 9:00 am

Your frames location is wrong.

It should be "G:/faceswap test/POLARRANA/videos/low to up.mp4" (not with the word "done" in it.... assuming you haven't renamed your alignments file)
My word is final

User avatar
allen621115
Posts: 3
Joined: Mon Mar 30, 2020 6:48 pm

Re: Strange error when"Extracting a training set from an alignments file"

Post by allen621115 » Tue Mar 31, 2020 11:23 am

OK, It's fine now,thank you again.


For those who has same problem with me. In my case,I change my frame video name after extracting my video to check that i have finished the video extracting.So I guess the alignments file did not get it.

After i change my video name back, i works.

Post Reply