Cannot update faceswap error

Installing and setting up FaceSwap


Forum rules

Read the FAQs and search the forum before posting a new topic.

Please mark any answers that fixed your problems so others can find the solutions.

Locked
User avatar
lorenzosale
Posts: 25
Joined: Thu May 28, 2020 11:58 am
Answers: 1
Has thanked: 12 times

Cannot update faceswap error

Post by lorenzosale »

Hi,

I dont understand why can't i update faceswap to the latest version, it says "Dependencies updated" but when I check again, it says that updates are availables

Thank you for your help

Here is the error message :

Code: Select all

02/07/2021 19:47:47 INFO     Checking for updates...
02/07/2021 19:47:47 INFO     A new version is available. Updating...
C:\Users\Blue\MiniConda3\envs\faceswap\lib\subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdout = io.open(c2pread, 'rb', bufsize)
Updating 2208eb3..6de2b31
error: Your local changes to the following files would be overwritten by merge:
scripts/gui.py
Please commit your changes or stash them before you merge.
Aborting
02/07/2021 19:47:48 INFO     An error occurred during update. return code: 1
02/07/2021 19:47:48 INFO     Updating dependencies...
02/07/2021 19:47:48 INFO     Setup in Windows 10
02/07/2021 19:47:48 INFO     Installed Python: 3.8.5 64bit
02/07/2021 19:47:48 INFO     Running in Conda
02/07/2021 19:47:48 INFO     Running in a Virtual Environment
02/07/2021 19:47:48 INFO     Encoding: cp1252
02/07/2021 19:47:48 INFO     Installed pip: 20.2.2
02/07/2021 19:47:50 INFO     All Dependencies are up to date
02/07/2021 19:47:50 INFO     Dependencies updated
02/07/2021 19:48:14 INFO     Checking for updates...
02/07/2021 19:48:15 INFO     There are updates available
by torzdf » Sun Feb 07, 2021 9:22 pm

Code: Select all

Your local changes to the following files would be overwritten by merge:
scripts/gui.py

This file has been edited.

Either revert the change in the file, or just delete your faceswap folder and reinstall.

Go to full post

User avatar
torzdf
Posts: 1372
Joined: Fri Jul 12, 2019 12:53 am
Answers: 125
Has thanked: 43 times
Been thanked: 270 times

Re: Cannot update faceswap error

Post by torzdf »

Code: Select all

Your local changes to the following files would be overwritten by merge:
scripts/gui.py

This file has been edited.

Either revert the change in the file, or just delete your faceswap folder and reinstall.

My word is final


Locked