Older installer version for Linux

Installing and setting up FaceSwap


Forum rules

Read the FAQs and search the forum before posting a new topic.

Please mark any answers that fixed your problems so others can find the solutions.

Post Reply
User avatar
lighting
Posts: 13
Joined: Thu Mar 02, 2023 6:54 pm
Has thanked: 2 times
Been thanked: 2 times

Older installer version for Linux

Post by lighting »

I have AMD RX580 card. DirectML not work for me entirly, so the only option i have is ROCm.
I made some research and find that gx803 is no longer supported by AMD so i can only install Tensorflow 2.2
If i understand correctly Tensorflow 2.2 support only python3.5-python3.8. In same time faceswap installer require python3.11
My question is - do you have older version of installer with python3.8 support or any other solution of my problem?

I use Ubuntu 20.04 (because older ROCm version did not support kernel higher than 5.4)

User avatar
torzdf
Posts: 2701
Joined: Fri Jul 12, 2019 12:53 am
Answers: 159
Has thanked: 136 times
Been thanked: 632 times

Re: Older installer version for Linux

Post by torzdf »

Your best bet will be to use the last version of Faceswap that supported PlaidML for AMD GPUs:

https://github.com/deepfakes/faceswap/r ... tag/v2.2.0

My word is final

User avatar
lighting
Posts: 13
Joined: Thu Mar 02, 2023 6:54 pm
Has thanked: 2 times
Been thanked: 2 times

Re: Older installer version for Linux

Post by lighting »

Thank you very much!
Aprox year ago i try to install faceswap on Win7, and constantly get unexpected freeze (i even made a topic abou that), so i migrate to Linux where faceswap work stable.
Now i try to install from your link (on Win 10) and it somwhow work stable! More over - on Linux i get 2,8 EGs/sec and nowi get 11,4-11,7 on a same hardware. I more than happy and need no Linux for this purpose.

Post Reply