Convert Function - Model could not be found ERROR

Converting source frames into swapped frames
Forum rules
Read the FAQs and search the forum before posting a new topic.

Please mark any answers that fixed your problems so others can find the solutions.
User avatar
Posts: 4
Joined: Sun May 31, 2020 9:31 am

Convert Function - Model could not be found ERROR

Post by RahulRookie »

Dear Experts, need some guidance

I am creating my video using latest version of Faceswap application

After Training the model, when I run Convert function, I am getting the following error message

Code: Select all

06/06/2020 14:31:01 ERROR    Model could not be found in folder 'D:\FACESWAP_PROJECTS\PROJECT_1\ModelAB'. Exiting

Need your help to know if I am doing anything wrong and how to fix this error, why it gives this error message when all the files present?

Thanks for your help

Output from Generate command

C:\Users\Rahul\MiniConda3\envs\faceswap\python.exe D:\faceswap\ convert -i D:/FACESWAP_PROJECTS/PROJECT_1/ -o D:/FACESWAP_PROJECTS/PROJECT_1/Output -m D:/FACESWAP_PROJECTS/PROJECT_1/ModelAB -c none -M none -sc none -w ffmpeg -osc 100 -l 0.4 -j 0 -t dfaker -otf -L INFO


06-06-2020 02.44 PM <DIR> .
06-06-2020 02.44 PM <DIR> ..
04-06-2020 08.56 AM 24,828,816 original_decoder_A.h5
04-06-2020 08.14 AM 24,828,816 original_decoder_A.h5.bk
04-06-2020 08.56 AM 24,828,816 original_decoder_B.h5
04-06-2020 08.14 AM 24,828,816 original_decoder_B.h5.bk
04-06-2020 08.56 AM 278,691,768 original_encoder.h5
04-06-2020 08.14 AM 278,691,768 original_encoder.h5.bk
04-06-2020 08.58 AM <DIR> original_logs
04-06-2020 08.56 AM 922 original_state.json
04-06-2020 08.14 AM 921 original_state.json.bk

User avatar
Posts: 1011
Joined: Fri Jul 12, 2019 12:53 am
Answers: 128
Has thanked: 28 times
Been thanked: 193 times

Re: Convert Function - Model could not be found ERROR

Post by torzdf »

I have never seen this before, and this looks fine on the face of it....

Triple check your paths, and check permissions on the model folder?

My word is final

User avatar
Posts: 39
Joined: Fri Jan 31, 2020 6:03 pm
Has thanked: 7 times
Been thanked: 3 times

Re: Convert Function - Model could not be found ERROR

Post by Tekniklee »

Just a note on this - the field can contain the correct file path and name, but you need to use the browse and select to get the file. Many times (such as switching from initial to final training sets) I have tried to just change the path or filename in the box. However, when the model runs, you get not found errors until you browse and select the actual file or folder. It's not like it tries to run using the old contents, but rather as though any manual update to the field sets it as no contents. As far as I know, this behavior is true on all screens, even things like log and timelapse files. Maybe capitalization sensitivity? Anyway, browse and select your model and other items it's not finding.

As a side note, it would be really nice to change the mouse hover on fields from item help to field contents, so you can just hover over a field to see it's full path, versus having to click on it and run the cursor to the left and right.